Freifunk mit USB-Tethering (LTE-Router)

Aus Freifunk München
Wechseln zu: Navigation, Suche

Diese Anleitung ist unter Verwendung eines TP-Link WR1043N mit einem LTE-Router Huawei 5573 entstanden. Android Phone USB Tethering funktioniert auch.

Teile dieser Anleitung kopiert von https://wiki.hacksaar.de/Freifunk:Mobiler_Hotspot.

Autoupdater deaktivieren[Bearbeiten | Quelltext bearbeiten]

Der Autoupdater sollte bis auf Weiteres deaktiviert werden, bevor Änderungen am Betriebssystem des Routers vorgenommen werden. Die Änderungen an Konfigurationsdateien sollten nach einem Update zwar noch erhalten sein, es ist aber möglich, dass individuell installierte Programme bzw. Software-Pakete durch ein Autoupdate ersetzt würden. Langfristig ist angedacht, USB Tethering standardmäßig an Freifunk-München-Routern mit USB-Port zu ermöglichen.

Deaktivierung des Autoupdaters:

uci set autoupdater.settings.enabled='0'
uci commit

Einrichtung eines USB-3G/4G/LTE-Dongles mit Gluon-USB-Dongles erlauben es, einen Freifunk-Router wie den TP-Link WR1043N V9 auch mobil zu benutzen, sofern für Stromversorgung gesorgt ist.[Bearbeiten | Quelltext bearbeiten]

Die Freifunk-Firmware kommt bisher ohne USB-Unterstützung. Diese kann aber nachträglich installiert werden:

opkg update
opkg install kmod-usb-core kmod-usb2 libusb-1.0 usb-modeswitch usbreset

Nach der Installation ist ein Neustart des Routers erforderlich:reboot && exit

Bei erfolgreicher Installation sollte jetzt die Datei /sys/kernel/debug/usb/devices existieren und nicht leer sein. Je nach Router-Modell können auch andere Pakete erforderlich sein.

Hinweis: Ein Freifunk-Netz kann sehr viel Traffic erzeugen, es ist also ratsam, einen ausreichenden Mobilfunkvertrag zu haben. Im folgenden nehmen wir zudem immer an, dass die SIM-Karte ohne PIN verwendet wird, da dies die Konfiguration teilweise enorm vereinfacht.

Je nach Art des UMTS-Sticks gibt es unterschiedliche Betriebsarten. Mittlerweile ist 'rndis' am weitesten verbreitet. Für USB legacy siehe https://wiki.hacksaar.de/Freifunk:Mobiler_Hotspot

USB-3G/4G-Dongle mit rndis (cdc-ether)[Bearbeiten | Quelltext bearbeiten]

Getestet mit Freifunk-Router TP-Link WR1043N und USB-LTE-Router Huawei E5573

opkg update
opkg install kmod-mii kmod-usb-net kmod-usb-net-rndis kmod-usb-net-cdc-ether

Nach der Installation ist ein Neustart des Routers erforderlich: reboot && exit

Ab hier sollte der USB-Dongle eingesteckt sein (falls er es vorher noch nicht war).

Anschließend muss die Konfiguration in /etc/config/network zum Beispiel mit dem Text-Editor vi angepasst werden:

  1. Das alte WAN-Interface muss umbenannt werden, damit es nicht zu Namenskonflikten kommt. Dazu ändere die Zeile config interface 'wan' etwa in config interface 'wan2'
  2. Nun legen wir ein neues WAN-Interface an, füge dazu am Ende der Datei hinzu:
    config interface 'wan'
            option igmp_snooping '0'
            option proto 'dhcp'
            option ifname 'eth2'
            option type 'bridge'
            option peerdns '0'
            option auto '1'

Nach einem Neustart sollte sich der Freifunk-Router über den 3G/4G-Dongle bzw. über Android Tethering ins Internet verbinden.

Konfig MR3020[Bearbeiten | Quelltext bearbeiten]

### Einrichtung USB-Tethering ###


# Paketquellen aktualisieren und nötige Pakete installieren :


opkg update



opkg install kmod-usb2 kmod-usb-net kmod-nls-base kmod-usb-net-rndis

kmod-usb-net-cdc-ether



# WAN-Interface auf USB-Schnittstelle legen:



uci del network.wan

uci set network.wan=interface

uci set network.wan.ifname=usb0

uci set network.wan.proto=dhcp

uci set network.wan.type=bridge

uci set network.wan.igmp_snooping=0

uci set network.wan.peerdns=0

uci set network.wan.auto=1

uci commit network



reboot & exit